Intune AutoPilot – invalid_client error failed%20to%20authenticate%20user

After the user credentials are validated in the Intune AutoPilot enrollment, the following error message comes up. invalid_client error failed%20to%20authenticate%20user. The detailed error is as below. Something went wrongLooks like we can’t connect to the URL for your organization’s MDM terms of use. Try again or contact your system administrator with problem information from this…

After the user credentials are validated in the Intune AutoPilot enrollment, the following error message comes up. invalid_client error failed%20to%20authenticate%20user.

The detailed error is as below.

Something went wrong
Looks like we can’t connect to the URL for your organization’s MDM terms of use. Try again or contact your system administrator with problem information from this page.
Additional problem information:
Error: invalid_client
Error subcode:
Description: failed%20to%20authenticate%20user

There are a few things to check to fix this issue.

  • Make sure that the user account has an Intune license. This was missing in my case and adding the license fixed the problem.
  • If you are using group based licensing, make sure that Intune license is turned on for the group.
  • Make sure that the MDM user scope within Intune is not set to ‘None’. If a group is used, make sure that the user account that is failing is part of that group.

One Comment

  1. Celine Moana Polamalu says:

    Know ur reasoning for doing what ur doing!

Leave a Reply

Your email address will not be published. Required fields are marked *